5×× Server Error

505 HTTP Version Not Supported

The server does not support, or refuses to support, the major version of HTTP that was used in the request message.

The server is indicating that it is unable or unwilling to complete the request using the same major version as the client, as described in Section 2.6 of RFC7230, other than with this error message. The server SHOULD generate a representation for the 505 response that describes why that version is not supported and what other protocols are supported by that server.


505 Code References

Rails HTTP Status Symbol :http_version_not_supported

Go HTTP Status Constant http.StatusHTTPVersionNotSupported

Symfony HTTP Status Constant Response::HTTP_VERSION_NOT_SUPPORTED

Python2 HTTP Status Constant httplib.VERSION_NOT_SUPPORTED

Python3+ HTTP Status Constant http.client.VERSION_NOT_SUPPORTED

Python3.5+ HTTP Status Constant http.HTTPStatus.VERSION_NOT_SUPPORTED

← Return to httpstatuses.com